VMware

After installing VMware Workstation, my OS (Ubuntu 19.10) boot time as doubled due to different vm services loading in Kernel. This there a way to initiate these services when only I open/use VMware?

There are many weird behaviors. My Laptop boot like this these days: Ubuntu purple screen > Dell logo > Ubuntu purple screen > Dell logo >> Ubuntu purple screen. This is weird. The normal boot should be like **Dell logo** > **Ubuntu purple** **screen** and that’s it.

So I decided to disable all VMware services. I don’t use an ethernet cable for ethernet to it was pointless to use those VM-services. Although disabling any of those services didn’t really change anything. I got the same loop of the slow boot as I told above.

TLDR;

1. Is there a way to use VMware without damaging my normal boot?
2. Can’t all services start on its own when I launch VMware software?
3. What to do VMware throws works without loading its services on kernel?

`VMware Workstation 15 Pro`


View Reddit by ArunzebView Source

Related Articles

4 Comments

  1. Not an expert, but probably not. The kernel modules need to be loaded, and probably in a certain order with other functions of the kernel as it processes. Kicking them off after may have unforseen consequences.

    I run Workstation 15 on top of OpenSuSE and my boot time is lightning fast, so I doubt it’s anything to do with the VMware modules, more likely something in your Ubuntu setup. The fact that you’re getting resets during boot up points to a bigger issue., a core instability that’s causing the boot process to crash.

    Have you tried a different distro…or older more stable verison of Ubuntu?

  2. Hi,

    I used to do exactly that in the past, but it was on another Linux version (no systemd in the mix).

    Then for starting VMware, instead of directly starting vmware I would start from a script.
    So yes, that is certainly do-able.

Leave a Reply

Your email address will not be published. Required fields are marked *

Close