VMware

ESXi Installer Not Responding to Keyboard Input // Cisco UCS

Hey all,

I’m been tasked with revamping a client’s tired UCS environment, beginning with a blade refresh (M2>M5). I’ve updated the infrastructure from 2.x up to 3.2(3) (using auto install) to support both the M2s and M5s in the environment, but I’m having an issue with the UCS KVM that neither Cisco TAC or VMWare has claimed as their own.

Anywho, the KVM functions fine on the older M2 blades, and will work in the boot selection menu on the M5. However, once I reach the ESXi installer screen (where you can [hit ESC or enter](https://i.imgur.com/I1Neen2.png)), both the physical and on-screen keyboard cease functioning. Same behavior in the web-based and standalone Java KVMs.

So far, I’ve tried the following with no success:

– Rolling the M5 blade’s CIMC controller back from 4.1 > 3.1

– Modified the BIOS settings in the UCS Service Profile to enable legacy USB/USB KVM and disable xHCI

– Booted several different versions of the ESXi installer (5.0/5.5/rollups)

Any ideas how to proceed from here? I’d really rather not have to travel on-site to hook up a USB keyboard to the internal USB port on the motherboard and hope it works lol



View Reddit by RobbbbbbbbbView Source

 

To see the full content, share this page by clicking one of the buttons below

Related Articles

3 Comments

  1. For grins and giggles have you tried installing a different OS like Windows or linux? When you get to the input sections for those OSes does your keyboard function? That should give you a big hint as to a UCS or a VMware issue.

    What version of firmware is installed on the FIs, blade servers? Make sure it is up to date and supports the new hardware.

    Have you tried different web browsers?

  2. I had that problem a few month ago with 6.0 and 6.5.

    As far as I remember I just rebooted that stupid box till it worked.
    Fun fact: when I made the experience even a keyboard didn’t function.

Leave a Reply