VMware

Install VMware Workstation 14.1.7 Pro for Linux… |VMware Communities

I have tried installing VMware Workstation 14.1.7 Pro for Linux on Ubuntu 18.04 LTS, but keep getting an error. 

 

I ran the following commands:

 

$ sudo chmod +x ~/Downloads/VMware-Workstation-Full-14*.bundle

$ sudo apt-get -y install gcc make linux-headers-$(uname -r) dkms

 

I than ran VMware using the icon and received the following pop-up:

 

     Before you can run VMware, several modules must be complied and loaded into the running kernel.

 

I then clicked Install, but an error is returned referencing /tmp/vmware-root/vmware-14536.log.  The best I can tell, everything is okay in /tmp/vmware-root/vmware-14536.log up until the following logs:

 

2020-01-03T15:22:36.582-05:00| vthread-1| I125: The header path “/lib/modules/5.0.0-37-generic/build/include” for the kernel “5.0.0-37-generic” is valid.  Whoohoo!

2020-01-03T15:22:36.721-05:00| vthread-1| I125: found symbol version file /lib/modules/5.0.0-37-generic/build/Module.symvers

2020-01-03T15:22:36.721-05:00| vthread-1| I125: Reading symbol versions from /lib/modules/5.0.0-37-generic/build/Module.symvers.

2020-01-03T15:22:36.739-05:00| vthread-1| I125: Read 23297 symbol versions

2020-01-03T15:22:36.739-05:00| vthread-1| I125: Invoking modinfo on “vmmon”.

2020-01-03T15:22:36.741-05:00| vthread-1| I125: “/sbin/modinfo” exited with status 256.

2020-01-03T15:22:36.741-05:00| vthread-1| I125: Invoking modinfo on “vmnet”.

2020-01-03T15:22:36.743-05:00| vthread-1| I125: “/sbin/modinfo” exited with status 256.

2020-01-03T15:22:37.174-05:00| vthread-1| I125: Setting destination path for vmmon to “/lib/modules/5.0.0-37-generic/misc/vmmon.ko”.

2020-01-03T15:22:37.174-05:00| vthread-1| I125: Extracting the vmmon source from “/usr/lib/vmware/modules/source/vmmon.tar”.

2020-01-03T15:22:37.182-05:00| vthread-1| I125: Successfully extracted the vmmon source.

2020-01-03T15:22:37.182-05:00| vthread-1| I125: Building module with command “/usr/bin/make -j8 -C /tmp/modconfig-HeMShg/vmmon-only auto-build HEADER_DIR=/lib/modules/5.0.0-37-generic/build/include CC=/usr/bin/gcc IS_GCC_3=no”

2020-01-03T15:22:38.878-05:00| vthread-1| W115: Failed to build vmmon.  Failed to execute the build command.

2020-01-03T15:22:38.880-05:00| vthread-1| I125: Setting destination path for vmnet to “/lib/modules/5.0.0-37-generic/misc/vmnet.ko”.

2020-01-03T15:22:38.880-05:00| vthread-1| I125: Extracting the vmnet source from “/usr/lib/vmware/modules/source/vmnet.tar”.

2020-01-03T15:22:38.885-05:00| vthread-1| I125: Successfully extracted the vmnet source.

2020-01-03T15:22:38.885-05:00| vthread-1| I125: Building module with command “/usr/bin/make -j8 -C /tmp/modconfig-HeMShg/vmnet-only auto-build HEADER_DIR=/lib/modules/5.0.0-37-generic/build/include CC=/usr/bin/gcc IS_GCC_3=no”

2020-01-03T15:22:40.846-05:00| vthread-1| W115: Failed to build vmnet.  Failed to execute the build command.

 

Any help to resolve would be appreciated.

 

Regards,

Ultrajones


Source link

Tags

Related Articles

Leave a Reply

Your email address will not be published. Required fields are marked *

Close