VMware

Issue Adding Host to Project in VIC

Hello everyone,

I’ll try to keep it brief and to the point. I recently purchased a VMUG license and installed a setup on my server at home for testing purposes.

I have vCenter installed along with a single ESXi host, deployed the VIC appliance and a VCH host.

The later I deployed without Client Certificate (homelab environment).

Now when I log in to the vic managment portal and try to add the vch to the default-project I get a ‘connection timeout’ error and the following line in the log:

2019/12/28 14:17:47 http: TLS handshake error from notebookIP:59756: remote error: tls: unknown certificate 2019/12/28 14:17:47 http: TLS handshake error from notebookIP:59757: remote error: tls: unknown certificate Dec 28 2019 14:17:47.963Z INFO User with a valid auth cookie at notebookIP is authenticated.

I filled out the form according to this guide:

[https://vmware.github.io/vic-product/assets/files/html/1.5/vic_cloud_admin/add_vch_serversideTLS_in_portal.html](https://vmware.github.io/vic-product/assets/files/html/1.5/vic_cloud_admin/add_vch_serversideTLS_in_portal.html)

if I do ‘docker -H vchIP:2376 –tls info’ I get the expected result

I do not get the prompt to accept the certificate as mentioned in the guide.

Any help greatly appreciated, I’m sure it’s probably something small I have overlooked

EDIT: I can run containers from commandline and they show up in vCenter with working Container network assigned, launched one for ubuntu but it shut’s down imediatelly after start. httpd keeps running.


View Reddit by Bean86View Source

Related Articles

Leave a Reply

Your email address will not be published. Required fields are marked *

Close