vSphere

Pass through not working |VMware Communities

Hi,

 

ESX 6.7 U2 with the latest update. This is a server machine, 2 Xeon, it has one Nvidia 2080 card. At one point I had a VM using the GPU, all was good. But I had to reinstalled ESX from scratch ( change to bigger disk), and now I can’t get it to work again.    Note that I have 2 other computers (different model) with V100 cards that are working ok so I’m assuming I know what needs to be done to get this working:

 

hypervisor.cpuid.v0 = “FALSE” 

pciPassthru.use64bitMMIO = “TRUE”  

pciPassthru.64bitMMIOSizeGB = “32”

 

However the VM won’t start. Noticed the “Failed to adjust IOMMU: Failure” “PANIC: PCIPassthru: failed to adjust IOMMU mappings”

 

020-02-13T23:59:52.927Z| vcpu-0| I125: Transitioned vmx/execState/val to poweredOn

2020-02-13T23:59:52.927Z| vcpu-0| I125: SCSIFilterSBDAttachCBRC: device scsi0:0 is not SBD. Skipping CBRC attach SBD way.

2020-02-13T23:59:52.927Z| vcpu-0| I125: Tools: Adding Tools inactivity timer.

2020-02-13T23:59:52.927Z| vcpu-0| I125: Intel VT: FlexPriority enabled.

2020-02-13T23:59:52.927Z| vcpu-0| I125: Intel VT: VPID enabled.

2020-02-13T23:59:52.929Z| vcpu-0| I125: Intel VT enabled.

2020-02-13T23:59:52.950Z| vcpu-0| I125: Failed to adjust IOMMU: Failure

2020-02-13T23:59:52.950Z| vcpu-0| E105: PANIC: PCIPassthru: failed to adjust IOMMU mappings.

2020-02-13T23:59:53.922Z| vcpu-0| W115: A core file is available in “/vmfs/volumes/5d606047-b33c61be-dfd6-ac1f6babb1ac/Malcom2080/vmx-zdump.001”

2020-02-13T23:59:53.925Z| vcpu-0| I125: Writing monitor file `vmmcores.gz`

2020-02-13T23:59:53.926Z| mks| W115: Panic in progress… ungrabbing

2020-02-13T23:59:53.926Z| mks| I125: MKS: Release starting (Panic)

2020-02-13T23:59:53.926Z| mks| I125: MKS: Release finished (Panic)

2020-02-13T23:59:53.928Z| vcpu-0| W115: Dumping core for vcpu-0

2020-02-13T23:59:53.928Z| vcpu-0| I125: VMK Stack for vcpu 0 is at 0x451a1e993000

2020-02-13T23:59:53.928Z| vcpu-0| I125: Beginning monitor coredump

 

If I remove the gpu from the virtual machine it starts just fine.

 

Suggestions?

 

Mario


Source link

Tags

Related Articles

Leave a Reply

Your email address will not be published. Required fields are marked *

Close