vSphere

vMotion between directly attached hosts with ne… |VMware Communities

Hello,

 

I have two hosts which I have connected directly via cross-over ethernet cables into their 1GbE NICs bypassing a switch.

I want to use this connection for vMotion and have followed all the instructions.

I created a new vSwitch (vSwitch2) on each host, with a vMotion VMKernel port group, and the vmnics (vmnic3) connected to the vSwitch.

The IP addresses (10.1.1.1/30 and 10.1.1.2/30) on a dedicated subnet distinct from the management and vmnetwork.

vMotion is enabled only on this switch. I can see 100MB/s network traffic between the dedicated NICs when I trigger a live migration, however…. It doesn’t work! Live migration fails at ~50%

It fails with this error “vMotion of a VM fails with the error: “Timed out waiting for migration data”

https://kb.vmware.com/s/article/2143834

 

 

I tried SSH into both the hosts to ping the other host.

 

[root@esx2d1:~] vmkping -v -I vmk1 -d -s 8972 10.1.1.2 -S vmotion
PING 10.1.1.2 (10.1.1.2): 8972 data bytes
8980 bytes from 10.1.1.2: icmp_seq=0 ttl=64 time=0.993 ms
8980 bytes from 10.1.1.2: icmp_seq=1 ttl=64 time=0.917 ms
8980 bytes from 10.1.1.2: icmp_seq=2 ttl=64 time=0.904 ms


--- 10.1.1.2 ping statistics ---
3 packets transmitted, 3 packets received, 0% packet loss
round-trip min/avg/max = 0.904/0.938/0.993 ms
[root@esx2d1:~]
[root@esx2d1:~]
[root@esx2d1:~] vmkping -v -I vmk1 -d -s 8972 10.1.1.1 -S vmotion
PING 10.1.1.1 (10.1.1.1): 8972 data bytes
8980 bytes from 10.1.1.1: icmp_seq=0 ttl=64 time=0.258 ms
8980 bytes from 10.1.1.1: icmp_seq=1 ttl=64 time=0.217 ms
8980 bytes from 10.1.1.1: icmp_seq=2 ttl=64 time=0.233 ms


--- 10.1.1.1 ping statistics ---
3 packets transmitted, 3 packets received, 0% packet loss
round-trip min/avg/max = 0.217/0.236/0.258 ms
[root@esx2d1:~]

 

 

[root@esx2d2:~] vmkping -v -I vmk1 -d -s 8972 10.1.1.2 -S vmotion
PING 10.1.1.2 (10.1.1.2): 8972 data bytes
8980 bytes from 10.1.1.2: icmp_seq=0 ttl=64 time=0.232 ms
8980 bytes from 10.1.1.2: icmp_seq=1 ttl=64 time=0.200 ms
8980 bytes from 10.1.1.2: icmp_seq=2 ttl=64 time=0.209 ms


--- 10.1.1.2 ping statistics ---
3 packets transmitted, 3 packets received, 0% packet loss
round-trip min/avg/max = 0.200/0.214/0.232 ms
[root@esx2d2:~]
[root@esx2d2:~]
[root@esx2d2:~] vmkping -v -I vmk1 -d -s 8972 10.1.1.1 -S vmotion
PING 10.1.1.1 (10.1.1.1): 8972 data bytes
8980 bytes from 10.1.1.1: icmp_seq=0 ttl=64 time=0.823 ms
8980 bytes from 10.1.1.1: icmp_seq=1 ttl=64 time=0.883 ms
8980 bytes from 10.1.1.1: icmp_seq=2 ttl=64 time=0.873 ms


--- 10.1.1.1 ping statistics ---
3 packets transmitted, 3 packets received, 0% packet loss
round-trip min/avg/max = 0.823/0.860/0.883 ms
[root@esx2d2:~]

 

 

Can someone help me please?

 

Thanks in advance.


Source link

Tags

Related Articles

Leave a Reply

Your email address will not be published. Required fields are marked *

Close