VMware

Still having Error 28 when upgrading? Enabled Swap? Try installing tools-light before

I was trying to upgrade to the latest release and got this error:

[InstallationError] [Errno 28] No space left on device
vibs = VMware_locker_tools-light_11.0.1.14773994-15160134
Please refer to the log file for more details.

I Googled, enabled swap, ensured plenty of disk space. No avail.

Previously I solved it by installing the no-tools one and applying the VIB later.

This time I turned it around, install the new VIB first and then apply the standard update, because that is the end result of the image.

cd /tmp
wget http://hostupdate.vmware.com/software/VUM/PRODUCTION/main/esx/vmw/vib20/tools-light/VMware_locker_tools-light_11.0.1.14773994-15160134.vib
esxcli software vib install -f -v /tmp/VMware_locker_tools-light_11.0.1.14773994-15160134.vib
esxcli network firewall ruleset set -e true -r httpClient
esxcli software profile update -p ESXi-6.7.0-20191204001-standard
> -d https://hostupdate.vmware.com/software/VUM/PRODUCTION/main/vmw-depot-index.xml
esxcli network firewall ruleset set -e false -r httpClient

Try it out. Let me know!

Edit: normal update script taken from https://esxi-patches.v-front.de/


View Reddit by AnnoyedVelociraptorView Source

Related Articles

Leave a Reply

Your email address will not be published. Required fields are marked *

Close