VMware

VMware Workstation 15 Pro showing black screen … |VMware Communities


If i open them manually works good, but if i use rest api for load them i get black screen in all machines.

 

Vmware workstation: 15.1.0 build-13591040

Windows10 version 1809 ( Compilation of OS 17763.557)

Api version: VMware Workstation REST API //vmrest 1.2.0 build-13591040

Virtual Machine OS: Windows 7

 

I have these python script for run the api and run the vms with api

[Python] import requests  import subprocess  from requests.auth import HTTPBasicAuth  imp – Pastebin.com

wich I call from a .bat file from task scheduler, like these vms start when i need them with a simple job

For start =

cd "C:UserslocalhostPycharmProjectsScripts PythonVM_Manager"
set VAR_1=On
python Main.py %1 %VAR_1%

 

for switch them off

cd "C:UserslocalhostPycharmProjectsScripts PythonVM_Manager"
set VAR_1=off
python Main.py %1 %VAR_1%

 

start task scheduler windows job

<?xml version="1.0" encoding="UTF-16"?>
<Task version="1.4" xmlns="http://schemas.microsoft.com/windows/2004/02/mit/task">
  <RegistrationInfo>
    <Date>2019-06-08T02:08:37.8509653</Date>
    <Author>DESKTOP-09RV55Jlocalhost</Author>
    <URI>MicrosoftWindowsUserTasksStart1</URI>
  </RegistrationInfo>
  <Triggers>
    <CalendarTrigger>
      <StartBoundary>2019-06-08T01:05:27</StartBoundary>
      <Enabled>true</Enabled>
      <ScheduleByDay>
        <DaysInterval>1</DaysInterval>
      </ScheduleByDay>
    </CalendarTrigger>
  </Triggers>
  <Principals>
    <Principal id="Author">
      <UserId>S-1-5-21-12982169-1001</UserId>
      <LogonType>S4U</LogonType>
      <RunLevel>HighestAvailable</RunLevel>
    </Principal>
  </Principals>
  <Settings>
    <MultipleInstancesPolicy>IgnoreNew</MultipleInstancesPolicy>
    <DisallowStartIfOnBatteries>true</DisallowStartIfOnBatteries>
    <StopIfGoingOnBatteries>true</StopIfGoingOnBatteries>
    <AllowHardTerminate>true</AllowHardTerminate>
    <StartWhenAvailable>false</StartWhenAvailable>
    <RunOnlyIfNetworkAvailable>false</RunOnlyIfNetworkAvailable>
    <IdleSettings>
      <StopOnIdleEnd>true</StopOnIdleEnd>
      <RestartOnIdle>false</RestartOnIdle>
    </IdleSettings>
    <AllowStartOnDemand>true</AllowStartOnDemand>
    <Enabled>true</Enabled>
    <Hidden>false</Hidden>
    <RunOnlyIfIdle>false</RunOnlyIfIdle>
    <DisallowStartOnRemoteAppSession>false</DisallowStartOnRemoteAppSession>
    <UseUnifiedSchedulingEngine>true</UseUnifiedSchedulingEngine>
    <WakeToRun>false</WakeToRun>
    <ExecutionTimeLimit>PT72H</ExecutionTimeLimit>
    <Priority>7</Priority>
  </Settings>
  <Actions Context="Author">
    <Exec>
      <Command>"D:Virtual MachinesStartAll.bat"</Command>
    </Exec>
  </Actions>
</Task>



Source link

 

To see the full content, share this page by clicking one of the buttons below

Related Articles

Leave a Reply